Modellgütekrietrien

Varianzanalyse, Diskriminanzanalyse, Kontingenzanalyse, Faktorenanalyse, Clusteranalyse, MDS, ....

Moderator: EDi

Antworten
Nadja
Beiträge: 3
Registriert: Mo Nov 12, 2018 9:36 pm

Modellgütekrietrien

Beitrag von Nadja » Mo Nov 12, 2018 9:54 pm

Hallo zusammen,

für meine Masterarbeit führe ich gerade eine konfirmatorische Faktorenanalyse durch. Bei dem Punkt "Modellgüte" komme ich aber einfach nicht weiter. Ich habe das Paket lavaan installiert und geladen, aber wenn ich dann den Befehl:

Code: Alles auswählen

fit <- cfa(model, data=enaz)
summary(fit)
durchführen will, kommt immer lavann ERROR und Objekt fit nicht gefunden. Ich weiß einfach nicht wieso. Kann mir hier vielleicht jemand helfen?

Vorher habe ich übrigens einige Variablen umkodieren müssen. In meiner Datenmatirx sind die neuen Variablen auch alle enthalten, sodass ich eigentlich nicht davon ausgehe, dass das eventuell zusammenhängt.

Vielen Dank im voraus und viele Grüße
Nadja

jogo
Beiträge: 1022
Registriert: Fr Okt 07, 2016 8:25 am

Re: Modellgütekrietrien

Beitrag von jogo » Mi Nov 14, 2018 8:37 am

Hallo Nadja,

willkommen im Forum!
Der primäre Fehler liegt dann wohl im Teil  cfa(model, data=enaz) dadurch kann das Objekt fit nicht erzeugt werden, welches deshalb anschließend nicht gefunden werden kann.

Gruß, Jörg

Nadja
Beiträge: 3
Registriert: Mo Nov 12, 2018 9:36 pm

Re: Modellgütekrietrien

Beitrag von Nadja » Mi Nov 14, 2018 10:06 am

Hallo Jörg,

vielen Dank :)

Glaubst du es liegt daran? Der Befehl müsste aber der richtige sein, oder etwa nicht? Könnte es vielleicht auch doch etwas mit der Umkodierung der variablen sein? Vielleicht erkennt R die umkodierten Variablen nicht und kann diese daher nicht in ein Model überführen? Ich bin total verzweifelt...

jogo
Beiträge: 1022
Registriert: Fr Okt 07, 2016 8:25 am

Re: Modellgütekrietrien

Beitrag von jogo » Mi Nov 14, 2018 10:32 am

Hallo Nadja,
Nadja hat geschrieben:
Mi Nov 14, 2018 10:06 am
Glaubst du es liegt daran? Der Befehl müsste aber der richtige sein, oder etwa nicht?
so wie ich das sehe, sollte dies die Stelle sein, die den Fehler erzeugt. Der Funktionsaufruf sieht so aus, als ob er syntaktisch richtig ist.
Könnte es vielleicht auch doch etwas mit der Umkodierung der variablen sein? Vielleicht erkennt R die umkodierten Variablen nicht und kann diese daher nicht in ein Model überführen?
Es ist sehr gut möglich, dass es an den Daten liegt. Allerdings hast Du uns bisher keinerlei Daten gezeigt (nichtmal die Struktur der Daten).
viewtopic.php?f=20&t=11
https://stackoverflow.com/questions/596 ... le-example
Ich bin total verzweifelt...
Dafür gibt es ein Zitat von DarkwingDuck ... ;)

Gruß, Jörg

Nadja
Beiträge: 3
Registriert: Mo Nov 12, 2018 9:36 pm

Re: Modellgütekrietrien

Beitrag von Nadja » Mi Nov 14, 2018 10:42 am

Ich will im Rahmen einer expolrativen Faktorenanalyse die Modellgütekriterien für ein Model berechnen lassen, welches im Grunde aus 2 Konstrukten besteht: Lohntransparenz + Arbeitszufriedenheit

Im Vorfeld habe ich eine Hauptkomponentenanalyse durchgeführt und anhand dieser, das unten stehende Modell aufgestellt. Aber es klappt einfach nicht.

Code: Alles auswählen

model <- '
BE =~ ENN01
T =~ Tarif2
LT =~ ENN03+ENN06+ENN08
AZB =~ B1+BB2+BB4+BB5+B3
AZT =~ T2+T5+T3+TT4+TT1+G1+G2+G4
AZV =~ V4+V1+V2+VV3+VV5
AZE =~ EE2+E1+EE4+E3+E5
AZK =~ K2+K1+K3+KK1+KK5
AZG =~ GG5+GG3
'
model

fit <- cfa(model, data=enaz)
summary(fit)

fitMesasures(fit)
fitMesasures(fit, c("rmsea", "srmr", "cfi", "pnfi", "gfi", "agfi"))

jogo
Beiträge: 1022
Registriert: Fr Okt 07, 2016 8:25 am

Re: Modellgütekrietrien

Beitrag von jogo » Mi Nov 14, 2018 10:52 am

Hallo Nadja,

bitte lies viewtopic.php?f=20&t=29
und formatiere zukünftig die entsprechenden Teile Deiner Nachrichten passend.

(Bisher hab ich das für Dich getan, damit Du sehen kann, wie es aussehen soll :!: )

Jetzt kennen wie das Objekt model aber die Daten, auf denen die Funktion arbeiten soll, kennen wir immer noch nicht. :?

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast