Probleme mit Legendenerstellung

Wie erstelle ich Grafiken, was ist zu beachten?

Moderatoren: EDi, jogo

Antworten
beneR
Beiträge: 2
Registriert: Mo Mär 05, 2018 11:44 am

Probleme mit Legendenerstellung

Beitrag von beneR » Mo Mär 05, 2018 11:51 am

Hallo liebes Forum,

leider sitze ich schon seit einiger Zeit an folgendem Problem: Die Legende in einem Plot hat nach unten keine Begrenzung und geht quasi über den Grafikbereich ins Nirgendwo hinaus. Wieso ist das so? Kann mir jemand helfen?

Hier der Code, der die Grafik mit der Legende erstellt:

Code: Alles auswählen

plot(table(HomicideByYear$`2016`$Month), col = "red", type = "l", main = "Morde nach Monaten in Chicago: 2015, 2016 und Durchschnitt von 2001 - 2017", ylab = "Morde", xlab = "Monate", ylim = c(0,100))

lines(table(HomicideByYear$`2015`$Month), type = "l", col = "blue")

legend(1, 100, legend = c("2015", "2016"), col=c("blue", "red"), lty=1:2, cex = 1)
Und hier die Grafik:
Legende Problem.PNG

ruedi_br
Beiträge: 13
Registriert: Do Mär 01, 2018 3:53 pm

Re: Probleme mit Legendenerstellung

Beitrag von ruedi_br » Do Apr 12, 2018 3:25 pm

Bislang habe ich das zweite legend (also legend = ) weggelassen. Liegt es ggf. an der expliziten Zuweisung? Ohne die konkreten Daten ist es etwas problematisch, selbst zu testen ...

beneR
Beiträge: 2
Registriert: Mo Mär 05, 2018 11:44 am

Re: Probleme mit Legendenerstellung

Beitrag von beneR » Sa Aug 18, 2018 9:21 am

Es lag an den Einstellungen über "par".

Hier die Lösung in den Kommentaren zur Frage: https://stackoverflow.com/questions/518 ... -correctly

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast