Das car Paket lässt sich nicht installieren

Wie erweitere ich R um eigene Funktionen oder Pakete? Welches Paket ist passend für meine Fragestellung?

Moderatoren: EDi, jogo

bigben
Beiträge: 2780
Registriert: Mi Okt 12, 2016 9:09 am

Re: Das car Paket lässt sich nicht installieren

Beitrag von bigben »

Kann es sein, dass Du eine alte R Version hast? Vielleicht immer noch 3.6? pbkrtest braucht mindestens Version 4.1!

Sonst probier doch mal, pbkrtest mit install.packages manuell zu installieren und schau Dir die Fehlermeldung dabei an.

LG, Bernhard
---
Programmiere stets so, dass die Maxime Deines Programmierstils Grundlage allgemeiner Gesetzgebung sein könnte
ruedi_br
Beiträge: 159
Registriert: Do Mär 01, 2018 3:53 pm

Re: Das car Paket lässt sich nicht installieren

Beitrag von ruedi_br »

Vielleicht hilft auch diese Info: https://stackoverflow.com/questions/759 ... g-rtools43
Grüße
Ruedi
fortune(111)
Athomas
Beiträge: 769
Registriert: Mo Feb 26, 2018 8:19 pm

Re: Das car Paket lässt sich nicht installieren

Beitrag von Athomas »

bigben hat geschrieben: So Apr 02, 2023 9:24 am Kann es sein, dass Du eine alte R Version hast? Vielleicht immer noch 3.6?
Das deutet ja schwer darauf hin:
Installing package into ‘C:/Users/XXX/Documents/R/win-library/3.6’
Außerdem muss die Rtools-Version zum R passen...
Benutzeravatar
student
Beiträge: 674
Registriert: Fr Okt 07, 2016 9:52 am

Re: Das car Paket lässt sich nicht installieren

Beitrag von student »

Mir ist immer noch nicht klar, ob Du ausschließlich versuchst, das Paket über die Konsole (oder Skript) zu installieren und zu laden, oder ob Du auch die RStudio-Menü-Möglichkeiten nutzt. Aber egal.

Du Schreibst, dass die Datei
car_3.1-2.tar.gz
noch im temporären Installationsverzeichnis liegt, also nicht ausgepackt wurde. Unter
R > R-4.2.2 > library
findest Du also nicht das Verzeichnis car und carData, richtig?

Hatte ich vor Jahren auch mal (nicht mit car) und konnte mir nur weiterhelfen, indem ich das Paket als zip-Datei heruntergeladen und dann über die R-Konsole installiert habe. Ich hatte damals als mögliche Ursache in Erwägung gezogen, dass mein Paketverzeichnis durch verschiedene Versionen "korrupt" war. Letztendlich habe ich alles gelöscht und neu installiert. Ist aber nur ein Erfahrungsbericht...
Dateianhänge
Pakete_Konsole.jpg
Viele Grüße,
Student
-----------------------------------------------------------------------------------------------------------------------
faes.de, Datenanalyse mit R & das Ad-Oculos-Projekt
Das Ad-Oculos-Projekt auf YouTube

Habe Mut, dich deines eigenen Verstandes zu bedienen! (Kant)
Athomas
Beiträge: 769
Registriert: Mo Feb 26, 2018 8:19 pm

Re: Das car Paket lässt sich nicht installieren

Beitrag von Athomas »

Unter

R > R-4.2.2 > library

findest Du also nicht das Verzeichnis car und carData, richtig?
Ich glaube, von 4.2.2 sind wir hier 3.5 Jahre entfernt :o !
Benutzeravatar
student
Beiträge: 674
Registriert: Fr Okt 07, 2016 9:52 am

Re: Das car Paket lässt sich nicht installieren

Beitrag von student »

wir hier 3.5 Jahre entfernt
... ist ja gut! Ich bin halt schon etwas älter und langsamer, werde aber gleich mal aktualisieren! ;) Ich mache mir nur sorgen, dass das mit den 3,5 Jahren tatsächlich glaubt und denkt, "Na, dann kann es bei mir ja nicht so schlimm sein!"! :lol:

So, gefühlte 20 Sekunden später: Aktualisiert! :mrgreen:
Viele Grüße,
Student
-----------------------------------------------------------------------------------------------------------------------
faes.de, Datenanalyse mit R & das Ad-Oculos-Projekt
Das Ad-Oculos-Projekt auf YouTube

Habe Mut, dich deines eigenen Verstandes zu bedienen! (Kant)
stefanz1991
Beiträge: 17
Registriert: Do Mär 30, 2023 5:07 pm

Re: Das car Paket lässt sich nicht installieren

Beitrag von stefanz1991 »

Hallo zusammen,

@student ich versuche das Paket über das Skript zu installieren.

Es kommt immer die Fehlermeldung:

WARNING: Rtools is required to build R packages but is not currently installed. Please download and install the appropriate version of Rtools before proceeding:

https://cran.rstudio.com/bin/windows/Rtools/
Installing package into ‘C:/Users/Stefa/Documents/R/win-library/3.6’
(as ‘lib’ is unspecified)

Rtools habe ich aber installiert.

Ich versuche mal die Variante mit alles löschen und wieder installieren.

Danke für die Tipps und den Hinweis.

Viele Grüße
bigben
Beiträge: 2780
Registriert: Mi Okt 12, 2016 9:09 am

Re: Das car Paket lässt sich nicht installieren

Beitrag von bigben »

bigben hat geschrieben: So Apr 02, 2023 9:24 amKann es sein, dass Du eine alte R Version hast? Vielleicht immer noch 3.6?
Ist es einfacher, alles neu zu installieren als diese Frage zu beantworten?
---
Programmiere stets so, dass die Maxime Deines Programmierstils Grundlage allgemeiner Gesetzgebung sein könnte
stefanz1991
Beiträge: 17
Registriert: Do Mär 30, 2023 5:07 pm

Re: Das car Paket lässt sich nicht installieren

Beitrag von stefanz1991 »

@bigben

Ich habe diese Version:

RStudio 2023.03.0+386 "Cherry Blossom" Release (99999999999999999999999999999999, 2023-03-09) for Windows
Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) RStudio/2023.03.0+386 Chrome/108.0.5359.179 Electron/22.0.3 Safari/537.36

Das müsste die neueste Version sein.
stefanz1991
Beiträge: 17
Registriert: Do Mär 30, 2023 5:07 pm

Re: Das car Paket lässt sich nicht installieren

Beitrag von stefanz1991 »

Das sind meine Versionen:

R:
R-4.2.3 for Windows

RStudio:
2023.03.0+386

Rtools:
RTools 4.3

Woran erkenne ich, ob die Versionen auch zueinander passen?
Antworten